Tried, Tested and Proven

Vulnerability Title:

Security Advisory 06-064 – Belkin Router G Plus Router (F5D7231-4) Administration Web Interface Vulnerable To Cross-site Scripting

Vulnerable System:

Belkin Router G Plus Router (F5D7231-4)

Vulnerability Discovery And Development:

Portcullis Security Testing Services. Further research was then carried out.

Credit For Discovery:

Nico Leidecker of Portcullis Computer Security Ltd.

Affected Systems:

Belkin G Plus Router (F5D7231-4), Firmware version 4.05.03, was tested as vulnerable.


The Belkin administration web interface is prone to a Cross-site Scripting vulnerability. The network’s administrator can overview a DHCP client list, where IP, MAC addresses and the hostnames are displayed. There is no sanitising for HTML and script code which could appear in the hostname.


An attacker might be able to execute arbitrary script code in the admins browser.


There is no exploit code required.


Copyright © Portcullis Computer Security Limited 2006, All rights reserved worldwide.
Permission is hereby granted for the electronic redistribution of this information.
It is not to be edited or altered in any way without the express written consent of Portcullis Computer Security Limited.


The information herein contained may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user’s risk. In no event shall the author/distributor (Portcullis Computer Security Limited) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.