Tried, Tested and Proven

Security Advisory 08-008 – ScrewTurn Wiki Permanent Cross-site Scripting

Vulnerability Title:

Permanent Cross-site Scripting in the “System Log” page.

Vulnerable System:

ScrewTurn Wiki (

Vulnerability discovery and development:

Portcullis Security Testing Services

Credit for Discovery:

Ferruh Mavituna – Portcullis Computer Security Ltd.

Affected Systems:

ScrewTurn Wiki 2.0.29 and 2.0.30 confirmed.
Potentially all older versions as well although, this has not been confirmed.


Following a request to any page will cause an error log because of the ASP.NET Request Validation.<script>alert(‘XSS’)</script>

This error will then be visible in the “/admin.aspx – System Log” page as unfiltered.


High, it is possible to hijack the admin session and from the admin panel it is possible to run .NET code via a plugin feature or to manage the whole application. The exploit does not require any authentication.


A <script>alert(‘XSS’)</script> request to any page in the application.

Vendor Status:

Vendor contacted, who advised that the vulnerability has been fixed in version 2.0.31.


Copyright © Portcullis Computer Security Limited 2008, All rights reserved worldwide.
Permission is hereby granted for the electronic redistribution of this information. It is not to be edited or altered in any way without the express written consent of Portcullis Computer Security Limited.


The information herein contained may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user’s risk. In no event shall the author/distributor (Portcullis Computer Security Limited) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.